Ganhe R$20 de desconto na primeira corrida com a 99Taxi!

Tag: apt-get

Configurando Proxy pelo Terminal no Linux Mint e Ubuntu para utilizar o apt-get

Se você está em uma rede em que um proxy precisa ser configurado manualmente e não está conseguindo utilizar o apt (Exemplo: apt-get update) no Linux Mint ou Ubuntu, pode ser necessário configurar manualmente o Proxy. Sendo assim, execute os abaixo no Terminal (CTRL + ALT + T):

No Linux Mint:

sudo pluma /etc/apt/apt.conf

No Linux Ubuntu:

sudo gedit /etc/apt/apt.conf

Se o proxy POSSUI usuário e senha, coloque o seguinte conteúdo no arquivo:

Acquire::http::proxy "http://Usuario:Senha@Servidor:Porta/";
Acquire::https::proxy "https://Usuario:Senha@Servidor:Porta/";
Acquire::ftp::proxy "ftp://Usuario:Senha@Servidor:Porta/";
Acquire::socks::proxy "socks://Usuario:Senha@Servidor:Porta/";

Se o proxy NÃO POSSUI usuário e senha, coloque o seguinte conteúdo no arquivo:

Acquire::http::proxy "http://Servidor:Porta/";
Acquire::https::proxy "https://Servidor:Porta/";
Acquire::ftp::proxy "ftp://Servidor:Porta/";
Acquire::socks::proxy "socks://Servidor:Porta/";

Pronto. Agora seu proxy está funcionando! Dúvidas? Pergunte nos comentários!

O procedimento foi testado no Linux Mint 17

Fonte: http://community.linuxmint.com/tutorial/view/2002


Instalando o PostgreSQL no Linux Mint ou Ubuntu

Para instalar o PostgreSQL no Linux Mint ou Ubuntu, primeiramente você precisa criar um arquivo "source" para ser utilizado com o apt-get.

Abra o Terminal (CTRL + ALT + T) e digite:

sudo touch /etc/apt/sources.list.d/pgdg.list

Depois edite o arquivo com o editor de sua preferência. Usarei o pluma (Linux Mint). No Ubuntu você pode usar o gedit.

sudo pluma /etc/apt/sources.list.d/pgdg.list

A configuração abaixo serve para o Linux Mint 17 ou Ubuntu 14.04 (Trusty). Caso esteja utilizando outra versão, será necessário utilizar o repositório adequado. Dentro do arquivo, coloque o seguinte conteúdo:

deb http://apt.postgresql.org/pub/repos/apt/ trusty-pgdg main

Salve o arquivo e digite as seguintes linhas (uma por uma):

sudo apt-get install wget ca-certificates -y
wget --quiet -O - https://www.postgresql.org/media/keys/ACCC4CF8.asc | sudo apt-key add -
sudo apt-get update -y
sudo apt-get upgrade -y
sudo apt-get install postgresql-9.4 pgadmin3 -y

Note que a linha "sudo apt-get upgrade -y" pode demorar bastante. O parâmetro -y serve para que não sejam feitas perguntas (sim para tudo).

Pronto! O PostgreSQL está instalado. Para este artigo foi utilizado o PostgreSQL 9.4 e o Linux Mint 17.

Agora você vai precisar definir uma senha para o PostgreSQL e em seguida pode começar a utilizá-lo!

Fonte: http://www.codeproject.com/Articles/898303/Installing-and-Configuring-PostgreSQL-on-Linux-Min

 


Resolvendo problema com Amarok no Linux: Após pausar música, volume volta em 100%

Essa é uma dica rápida pra quem está passando por esse problema. Aconteceu comigo e após uma pequena pesquisa, consegui resolver.

O procedimento foi testado no Linux Mint Debian Edition, mas deverá funcionar normalmente no Ubuntu e Debian.

Pelo que pesquisei, o problema não é no Amarok, mas sim no Phonon, que é uma API multimídia criada para abstrair o gerenciamento multimídia no KDE. Além de outras coisas, isso faz com que o Amarok possa funcionar no Windows e MacOS, por exemplo.

Enfim, sem entrar em maiores detalhes, o post que encontrei me sugeriu trocar o pacote phonon-backend-vlc pelo phonon-backend-gstreamer. Pra isso, digite o seguinte no Terminal:

sudo apt-get update
sudo apt-get remove phonon-backend-vlc
sudo apt-get install phonon-backend-gstreamer

Depois é só fechar e abrir o Amarok, que deve funcionar normalmente. Pelo menos funcionou comigo 🙂

Mais informações:


Repositórios de versões antigas do Ubuntu

O caso é esse: você tem uma versão do Ubuntu instalada em sua máquina, mas não pode ou não quer atualizar para uma versão nova. Assim que a versão sai do suporte, os repositórios oficiais são tirados do ar. E agora? O que fazer?

Parabéns! Você acabou de encontrar a solução para o seu problema! 🙂

A Canonical mantém repositórios de arquivo para as versões antigas. Assim você pode alterar o endereço no sources list (/etc/apt/sources.list) e assim continuar podendo utilizar o apt-get e aptitude normalmente. Os repositórios ficam aqui: http://old-releases.ubuntu.com/ubuntu/dists/

Lembrando que utilizar uma versão sem suporte não o ideal nem o mais seguro. Só faça isso em último caso.

Até o momento, as distribuições que já estão sem suporte são essas:

 

 

Clique na imagem para ampliar. Fonte: http://pt.wikipedia.org/wiki/Ubuntu

 

 


Instalando o PostgreSQL 9 e pgAdmin III no Ubuntu 10.04

Versão atualizada desse artigo

Sem muita conversinha, vamos direto ao assunto. Para instalar o PostgreSQL 9 e o pgAdmin III no Ubuntu 10.04, acesse o Terminal (Menu Principal / Acessórios / Terminal) e digite os seguintes comandos:

sudo add-apt-repository ppa:pitti/postgresql
sudo apt-get update
sudo apt-get upgrade
sudo apt-get install postgresql
sudo apt-get install pgadmin3

O que você acabou de fazer foi instalar o PosgreSQL a partir de um repositório PPA, ou seja, um repositório que não faz parte da distribuição oficial, que traz a versão 8.4.

Depois de instalar, você vai precisar criar a senha para o usuário padrão do posgresql. Veja como fazer isso clicando aqui.

Se você não conseguiu abrir o PgAdmin depois de instalar, veja aqui como resolver.


Como instalar o Hamster no Ubuntu Linux

O hamster é um gerenciador pessoal de tempo. Com ele você tem como saber quanto tempo gastou em uma atividade ou outra, e até gerar relatórios sobre suas atividades.

Para instalar o Hamster no Ubuntu:

  1. Abra o Terminal (Aplicativos / Acessórios / Terminal)
  2. Digite os seguintes comandos:

 

sudo apt-get update
sudo apt-get install hamster-applet

Depois é só acessar o programa no Menu Aplicativos / Acessórios / Gestor de tempo

O procedimento foi testado no Ubuntu 10.04 LTS, mas deverá funcionar normalmente em outras versões.


Montando Automaticamente Partições NTFS no Linux Debian Lenny

O Debian Lenny (5.0) não monta partições NTFS por padrão. Irei mostrar como fazer isso, e como fazer o sistema montar automaticamente quando é inicializado.

Abra o Terminal (Aplicações -> Acessórios -> Terminal)

digite:

su

Baixe o pacote ntfs-3g:

apt-get install ntfs-3g

Crie o diretório onde a partição será montada:

mkdir /media/windows

Monte a partição

mount -t ntfs-3g /dev/sdaX /media/windows

No caso, sdaX deve ser subtituido pela referência certa à partição que você quer utilizar. Se você não sabe que referência é essa, você pode ver pelo GParted. Caso não tenha instalado, é simples:

apt- get install gparted

Depois vá em Sistema -> Administração -> Partition Editor. Lá vai ter os códigos das partições.

Depois que você montou a partição, agora você deve configurar pra que ela seja montada quando o sistema iniciar: Abra o arquivo /etc/fstab:

gedit /etc/fstab

Acrescente a seguinte linha ao final do arquivo:

/dev/sdaX     /media/windows ntfs-3g defaults 0 0

Lembre de substituir o sdaX pelo valor certo.

Pronto! 🙂


Instalando o JDownloader no Linux Debian 5.04 (Lenny)

O JDownloader é um software que automatiza o download de arquivos a partir de sites como Rapidshare, Megaupload etc. Com ele, não existe mais a necessidade de ficar esperando um download acabar pra poder começar outro. Muitas vezes ele até digita o código captcha sozinho pra você! 🙂

Bem. Vamos começar então. Antes de tudo se assegure que está com os repositórios atualizados. Veja aqui como fazer isso:

http://blog.tiagopassos.com/2010/12/21/atualizar-repositorios-no-linux-debian-5-04-lenny/

Depois disso, é necessário entrar no Terminal (Aplicações/Acessórios/Terminal). Digite su para logar como root, e depois senha. Será necessário instalar o Java. Para isso você terá que baixar alguns pacotes com as seguintes linhas de comando. É possível baixar todos em um comando só, mas por algum motivo que desconheço deu erro quando fiz isso. Então vamos baixar linha por linha:

apt-get install openjdk-6-jre
apt-get install sun-java6-jre
apt-get install default-jre
apt-get install zenity
apt-get install sun-java6-bin
apt-get install openjdk-6-jre-headless

Se você não estiver com o Java instalado antes de usar o JDownloader pode dar o seguinte erro (ou algo parecido):

Exception in thread "main" java.lang.NoClassDefFoundError:
jd.update.Main   at java.lang.Class.initializeClass
(libgcj.so.90)Caused by: java.lang.ClassNotFoundException:
com.sun.java.swing.plaf.windows.WindowsLookAndFeel
not found in gnu.gcj.runtime.SystemClassLoader
{urls=[file:jdupdate.jar], parent=gnu.gcj.runtime.
ExtensionClassLoader{urls=[], parent=null}}
at java.net.URLClassLoader.findClass(libgcj.so.90)
gnu.gcj.runtime.SystemClassLoader.findClass(libgcj.so.90)
java.lang.ClassLoader.loadClass(libgcj.so.90) at java.lang.
ClassLoader.loadClass(libgcj.so.90)  at java.lang.
Class.forName(libgcj.so.90)at java.lang.Class.
initializeClass(libgcj.so.90)

Depois que o Java estiver instalado, baixe um pacote .deb da última versão do JDownloader no site:

https://launchpad.net/~jd-team/+archive/jdownloader/+packages

Quando o pacote tiver baixado, vá na pasta onde você salvou ele. Se ele estiver em /home/tiagopassos, por exemplo, digite:

cd /home/tiagopassos

Execute o dpkg. LEMBRANDO QUE O NOME DO ARQUIVO DEVERÁ SER O DO ARQUIVO QUE VOCÊ BAIXOU! Veja o exemplo abaixo:

dpkg -i dpkg -i jdownloader_0.1-0jd1~maverick1_all.deb

Pronto! Abra o JDownloader (Aplicações/Internet/JDownloader) e espere baixar todos os arquivos. Tenha paciência, pois pode demorar um pouco. Depois disso ele deve abrir automaticamente 🙂


Atualizar repositórios no Linux Debian 5.04 (Lenny)

A princípio o Debian vem apenas com os repositórios de segurança configurados, e talvez seja necessário que você configure manualmente caso queira instalar algum pacote utilizando o apt-get.

Para fazer essa atualização, você tem que modificar o arquivo /etc/apt/sources.list. Pra isso, clique em Aplicações, Acessórios, Terminal. Depois é necessário se tornar root. Então digite:

su

Digite a senha de root, e em seguida edite o arquivo:

gedit /etc/apt/sources.list

Você pode apagar o conteúdo do arquivo, mas é recomendável que você apenas comente (colocando um # na frente de cada linha). Depois preencha o arquivo com as seguintes linhas:

deb http://ftp.br.debian.org/debian lenny main contrib non-free
deb-src http://ftp.br.debian.org/debian lenny main contrib non-free
deb http://security.debian.org lenny/updates main
deb-src http://security.debian.org lenny/updates main

Salve o arquivo, feche o Gedit e volte para o Terminal. Lá digite:

apt-get update

Pronto. Agora você já pode baixar seus pacotes pelo apt-get.


Instalar Flash Player no Ubuntu 10.04 64 bits

Tive algumas dificuldades para instalar o plugin do Flash no Ubuntu 10.04 64 bits. Mas encontrei a solução, que é bem simples. Possivelmente funcionará com versões posteriores e anteriores.
Basta colar esses comandos no Terminal (Aplicativos / Acessórios / Terminal) e reiniciar o Firefox, que deverá funcionar.

sudo apt-get install ubuntu-restricted-extras

  • Publicidade

  • Redes Sociais

    Facebook  Twitter
  • Projetos Paralelos

  • Estatísticas

    Page Views (desde março de 2010):

    Estatísticas detalhadas
  • Novidades por e-mail!

    Digite seu e-mail:


    Fique tranquilo. Seu e-mail não será usado para outros fins, e você poderá se descadastrar quando quizer.

    Eu!

    Tiago Passos
    Todo o conteúdo desse site esta licenciado sob a licença Creative Commons 3.0 (CC BY 3.0). Você pode copiar e modificar o conteúdo desde que cite o autor.
    iDream theme by Templates Next | Powered by WordPress